Archive

Posts Tagged ‘visio’

ThinApp Notes

January 12th, 2011

So I’ve started playing around with ThinApp recently. The main reason is that I have a little NetBook (Samsung N150 running Windows 7 if you are interested) I use for running around the country with and I want this to be light weight, easy to rebuild and little inconvenience if it gets destroyed or lost. So I’m not looking at using this for enterprise deployments, just personal convenience. I’m new to application packaging too, so I’m learning a few lessons as I go! I’ll add a few of my observations here.

I’m building this on my home desktop PC running a clean Windows XP virtual machine. I read up on dependencies of dotNET, so although it’s updated, I put off installing all dotNET patches. I regularly snapshot this at various stages of application builds to allow me to go back, add updates and rebuild applications as appropriate. Hasn’t come to that yet, but I feel it’s a good practice!

Microsoft Office 2010 is a bit of a challenge still. It looks like this is due to the new way Microsoft handle the licensing of the product, even if you want to run a personal edition and authenticate online. This has forced me to still use 2007, which isn’t so bad as it’s less of a resource hog and so lightens the load on my NetBook. It’s a shame there isn’t a single Office package that includes Visio, OneNote and Project, so I have to package it 3 times, no biggie.

I made the mistake (I think) of installing Office, and packaging that up, then installing Visio and packaging that up separately. I think I’ve introduced an odd dependency between the 2 packages now as it runs fine on my vanilla NetBook, but trying to run Visio on my desktop now fails with an error. Something I need to investigate. Apparently “The operation system is not presently configured to run this application”.

General , , , , ,



This site is not affiliated or sponsored in anyway by NetApp or any other company mentioned within.